[freeside] Problem with freeside-daily in 1.5.0Pre6

James McDonald james at homelandinternet.com
Thu Apr 28 19:43:48 PDT 2005

It looks like this was a problem with the Invoice Events that were 
defined. I re-created them and was able to bill. A different problem 
came up as a result, however. Most of our credit card customers were 
not billed by freeside-daily, but their next bill date was incremented 
ahead one month as if they had been. Some customers with outstanding 
invoices from previous months were billed, but no new invoices were 
generated. I did this same process every month with 1.41, but I was 
batching the charges in cust_pay_batch. I am now doing real-time 
charges against Authorize.net, so I don't know if this is something to 
do with the differences between the way Freeside handles batch vs 
reatime processing.

Any thoughts?

On Apr 28, 2005, at 10:56 AM, James McDonald wrote:

> Platform: Freeside 1.5.0pre6, FreeBSD 5.3, Perl 5.8.6, Postgres 8, 
> BusinessOnlinePayment for Authorize.net
> I'm running freeside-daily with the -d option set to 5/1/2005 and -p 
> set to CARD and receive the following errors repeating on the screen:
> Argument "" isn't numeric in division (/) at 
> /usr/local/lib/perl5/site_perl/5.8.6/FS/part_pkg/prorate.pm line 41.
> Argument "" isn't numeric in sprintf at 
> /usr/local/lib/perl5/site_perl/5.8.6/FS/cust_main.pm line 1250.
> No invoices are generated and the card is not charged.
> I looked at the code referenced and it looks like it is trying to 
> calculate any pro-rate needed for the invoice. I verified that the 
> package is set to the correct recurring period.
> Any ideas?

More information about the freeside-users mailing list